Install HP LaserJet P1108 printer in Debian 8 and Ubuntu 16.04

You can find that HP LaserJet P1108 does not work simply adding printer with Ubuntu 16.04 and Debian 8. Installation of HP driver fail to install plugin file. You will get following error message,

“HP Device Manager – Plug-in Installer(X) file does not match its checksum. File may have been corrupted or altered”




Install HP Printer packages

sudo apt-get install hplip hplip-dbg hplip-gui hplip-cups

Check the version of hplip

dpkg -l hplip

Download and install missing plugins match with the hplip version from the following link (check the version number)

https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/

Following command will install the plugin (give the exact name of the plugin)

sudo sh hplip-3.15.2-plugin.run

Run following command to configure the printer.

sudo hp-setup

User settings,

sudo adduser vimal lp
sudo adduser vimal lpadmin

Replace vimal with your user name.

References
https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/1476011
http://hplipopensource.com/node/306

Linux Halwa

This entry was posted in Technology and tagged , , , , , , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *

* Copy This Password *

* Type Or Paste Password Here *